Security warnings when logging into Ministry Sync

We recently updated our security certificate for Ministry Sync, but some computers still have the old expired versions in their keychains.  This affects Mac OSX particularly, but other computers that store security certificates in keychains may be affected as well.

If you log into Ministry Sync and see a warning like this, 



or this



you need to delete an old certificate in your computer.
  • In Keychain Access go to View -> Show Expired Certs
  • Search for ‘DigiCert High” to find the DigiCert High Assurance EV Root CA that expired on July 26, 2014. 
  • Delete this certificate and close Keychain Access.
You can read more about this issue on DigiCert's website.

Feedback and Knowledge Base